What are the minimum requirements for accessing the mhub platform?

To access the mhub platform at https://mhub6.mhub.tv you will require the following:

1) Adobe Flash Player version 11.1 or above.

2) One of the following web browsers:

  • Internet Explorer 9 or above
  • Firefox 15 or above
  • Chrome 14 or above
  • Safari 5 or above
  • Opera 12.10

How do I check which version web browser I'm running?

Visit www.useragentstring.com and it will load a webpage that will show you what version you are running.


How do I check which version of flash I'm running?


Have more questions? Submit a request


Please sign in to leave a comment.
Powered by Zendesk