What are the minimum requirements for viewing mhub content in a web browser?

The following version web browsers are required to view mhub content correctly:

  • Internet Explorer 9 or above
  • Firefox 15 or above
  • Chrome 14 or above
  • Safari 5 or above
  • Opera 12.10

If you are running an old web browser you will automatically be redirected to a compatible version of the content. However, the content may not look as good due to the limitations of older browsers.

How do I check which version web browser I'm running?

Visit www.useragentstring.com and it will load a webpage that will show you what version you are running.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk